Problematic dependencies: RedCloth 3.0.4 and Rake 0.6.0

Two of the frequent dependencies for Rails applications, RedCloth and Rake, both have problems in their latest releases. So you want to install the version just behind the latest. Install RedCloth 3.0.3 and Rake 0.5.4. Hopefully we can get the problems sorted out quickly.